The connection to the server localhost:8080 was refused - did you specify the right host or port?


The error in the title may appear when running kubectl commands.

This error message indicates one of two things:

1.  The path to a kubernetes config file has not been set as an environmental variable

export KUBECONFIG=/etc/kubernetes/admin.conf

After running the export command, kubectl commands should execute as expected.  If the commands continue to throw the error message, proceed to Option 2 below.

2.  The kubelet service is not running

systemctl status kubelet

Option 2 may need to be run a couple times, as the service could be in state where it is starting, activating or running (but crashing).  If the service does not stay in a running state after a few checks, then please submit a support ticket to Customer Success.




Please sign in to leave a comment.

Didn't find what you were looking for?

New post