[4.9] Patch- September 26, 2022

Fortanix Data Security Manager (DSM) 4.9.2109 release provides an overview of the resolved issues.

WARNING
It is “REQUIRED” to upgrade Fortanix DSM to version 4.6 or 4.8 before upgrading to the 4.9.2109 version. If you want to upgrade to the 4.9.2109 version from an older version, please reach out to the Fortanix Customer Success team.
NOTE
The Fortanix DSM cluster upgrade must be done with Fortanix support on call. Please reach out to Fortanix support if you are planning an upgrade.

1. Bug Fixes

  • Fixed an issue where plugins were forbidden from calling get_user and get_app API for admin apps (JIRA: PROD-5421).
  • Fixed an issue that prevented users from getting into the DSM web UI during the failover test (JIRA: ES-104).

2. Known Issues

  • An account could be lost if account tables are inconsistent between nodes. Make sure a backup is successful before proceeding with ANY upgrade (JIRA: PROD-4234).
  • When a node is removed from a 3-node cluster with build 4.2.2087, and the 2-node cluster is upgraded with build 4.3.xxxx, it is possible that the deploy job is exited and marked completed before cluster upgrade (JIRA: DEVOPS-2068). Workaround: If all the pods are healthy, you can deploy the version again.
  • The sync key API returns “400 status code and response error” due to the short-term access token expiry during the sync key operation of a group linked to AWS KMS (JIRA: PROD-3903).
  • exclude does not work in the proxy config for operations such as attestation (JIRA: PROD: 3311).

For the new features, enhancements to existing features, and other improvements please refer to the full description of the 4.9 release on our support portal.

4. Installation

To download the DSM SGX (on-prem/Azure) and Software (AWS/Azure/VMWare) packages, click here.

Comments

Please sign in to leave a comment.

Was this article helpful?
0 out of 0 found this helpful