[4.16] Patch - February 27, 2024

Fortanix Data Security Manager (DSM) 4.16.2367 release provides an overview of resolved issues. 

This release is superseded by the March 11, 2024, release.

WARNING
  • You are REQUIRED to upgrade Fortanix DSM to version 4.11 or 4.13 before upgrading to version 4.16.2367. If you want to upgrade to 4.16.2367  from an older version, please reach out to the Fortanix Support team.
  • After upgrading to version 4.16.2367, Fortanix DSM can NO LONGER be downgraded to any prior version. This is due to limitations of common infrastructure components such as Docker and Kubernetes.
WARNING
  • The Fortanix DSM cluster upgrade must be done with Fortanix support on call. Please reach out to Fortanix support if you are planning an upgrade.
  • The customer's BIOS version must be checked by Fortanix Support before the Fortanix DSM software upgrade. If required, the BIOS version should be upgraded to the latest version and verified by Fortanix Support for a smooth upgrade.
  • If your Fortanix DSM version is 4.13 or later, then the HSM gateway version must also be 4.13 or later. Similarly, if the HSM Gateway version is 4.13 or later, then your Fortanix DSM version must be 4.13 or later.

1. Bug Fixes

  • Fixed an issue where, due to incorrect computation of leap year future dates, it will cause Fortanix Plugins to crash on February 29th, 2024 (JIRA: PROD-8274).

For a complete list of new features, enhancements to existing features, other improvements, and bug fixes refer to the full description of the 4.16 DSM on-prem and SaaS release.

3. Installation

To download the DSM SGX (on-prem/Azure) and Software (AWS/Azure/VMWare) packages, click here.

Comments

Please sign in to leave a comment.

Was this article helpful?
0 out of 0 found this helpful